GCASH: This app isn't compatible with your device anymore. Contact the developers for more info.

Before, when I am installing GCash on my Android 4 phone, I always got an error message saying, This app isn't compatible with your device anymore. Contact the developers for more info. I suspected that my phone is the one causing the error, but its just the Google Play. Maybe my Google Play is outdated and needs an update. But good thing, there is an app called Aptoide, wherein I can easily install my GCash inside my phone or even my tablet. See the simple tutorial below.


GCASH: This app isn't compatible with your device anymore. Contact the developers for more info.



1. Open your Google search.
2. Type: aptoide apk download, or you can directly go to Aptoide website here.
3. Click the Download button, to start downloading your Aptoide APK file.
4. After downloading open your APK file. Make sure to Enable Unknown Sources. Just go to your phone Settings, choose Security and enable Unknown Sources.
5. When done installing, open your Aptoide now.
6. Tap the search icon (magnifying glass).
7. Type GCash.
8. Click the GCash link that will appear in the result.
9. Inside GCash app page, click the Install button.
10. Wait for the download to finish.
11. If needed click Install again to install GCash.
12. After installation, try to log in your GCash account.
13. Done!

Note: This method is both working in Android phone and Android emulator like Bluestacks, NOX, and LDPlayer.

Do Not Sell My Personal Information
- LISTPH.COM